Thursday, July 21, 2011

Route Redistribution & Metrics in EIGRP-OSPF with ASBR & ABR Routers

Here is one more topology I busted, Route Redistribution in EIGRP-OSPF with routers playing different ASBR/ABR roles. This involves 10 Router configurations. Basically, In Route redistribution we are allowing one routing process to distribute his own routes into another routing process with different metrics & parameters. This also includes Route-Mapping which I will cover in another topology. So if a router has EIGRP & OSPF procotol running, then "redistribute ospf <<process id>>" statement in EIGRP router plane will allow the OSPF routes to be distributed into respective EIGRP zone. However you have to take care of metrics & AD phenomena at the time of redistribution. Both protocols follow different type of metric sets. Auto-Summary is needed by EIGRP in this topology.



Notes - 
  • Router R3 & R10 are connecting OSPF & EIGRP protocols. Think of this like two Companies have a merger with one running EIGRP & Other OSPF in backbone.
  • R5 & R6 are in OSPF area 0 with R5 as ABR.
  • Routes are redistributed into each of the Router planes.
  • Routers in EIGRP region sees all external routes as EIGRP  External. "sh ip route" shows it as D EX flag.
  • Routers in OSPF region sees all external EIGRP routes as OSPF external 2 routes. "sh ip route" shows it as O E2 flag.
  • Routers in OSPF region sees all external OSPF routes as OSPF Inter-area. "sh ip route" shows it as O IA Flag
  • Redistributed Routes into OSPF are E2 type by default. Remember complete end to end cost is not reflected when route is detected as E2. E1 i.e. External Type 1 reflects total end to end cost of the route. This can be done using "metric-type 1" at the time of redistribution of protocols into OSPF routing process. Here Routes E2 type.
  • R10 connects EIGRP AS130 with OSPF Area 20. Redistribution of OSPF Area 20 routes into  EIGRP AS 130 follows different metrics. EIGRP protocol works with K values so at the time of redistribution of routes following metrics are required
      • Bandwidth
      • Delay in milliseconds
      • Reliability
      • Line Load
      • MTU
  • I have used standard metrics for Redistributing OSPF routes into EIGRP "56000 10 255 255 1500" in all routers except for R10 Router. Keeping same metrics while redistributing EIGRP AS120 into EIGRP AS130 & redistributing OSPF Area 20 into EIGRP AS130 causes routing black-hole. R12 finds two paths to go for the desired network with equal cost. Hence to avoid this while redistributing OSPF into EIGRP at R10 metrics used are "56000 12 255 255 1500". Notice the Delay value present 12 ms delay result in EIGRP choosing low delay 10 ms link over this route. Hence R12 chooses 61.1.1.2 interface to route to external networks. 102.1.1.2 is only chosen in case of very near networks in OSPF Area 20 region.
  • If 61.1.1.0 network goes down then 102.1.1.0 network will be used for all the routing.
  • Cloud interfaces bridged with Oracle Virtual Box Interfaces are connected to Microcore Linux to verify the network. SW2 with VLAN 4 & 2 connected to Microcore.
All the Router configurations can be downloaded from here


Happy Networking!

Thursday, July 7, 2011

First Hop Redundancy Protocols Part 3 - Object tracked GLBP Load balancing with OSPF routing

GLBP(Gateway Load Balancing Protocol) helps us to achieve load balancing with fault tolerance. In HSRP/VRRP there is only one Active/Master router. In GLBP highly flexible network can be configured with the help of AVG(Actual Virtual Gateway) & AVF(Actual Virtual Forwarder) planes.

  • In same GLBP group, there is only one AVG. 
  • Same GLBP group can have multiple AVF. Two AVF's are default.
  • Key point in working of GLBP is, only AVG replies to ARP requests of the clients. Every AVF is configured with virtual MAC address, AVG router in GLBP group sends MAC addresses to clients. Load-balancing is achieved by replying with different ARP replies.
  • AVG is elected on the basis of priority configured. Backup AVG remains in standby mode and responds if primary AVG fails. 
  • Load balancing & redundancy is achieved by AVF. Active & Backup AVG has two AVF's  independently. Every AVF has its own Virtual MAC address assigned by AVG.
  • AVF's are always in active state with respect to each other. Higher weight AVF will be in active state while other one is in Listen state. So Active AVG router can have Forwarder 1 in Listen state & Forwarder 2 in Active state, Standby AVG can have Forwarder 1 in Active state & Forwarder 2 in Listen state. Active AVG will distribute the MAC addresses to ARP queries depending upon the Load balancing algorithm configured.
  • AVF can be changed to Listen state if the weight goes below the threshold. Then this AVF will stop forwarding traffic & active AVG will not advertise these virtual MAC address.
  • In current scenario, both the GLBP groups are tracking s0/0 interfaces. If s0/0 goes down the priority decreases by value of 10. The weight set is 200 with threshold of 191. So as soon as the s0/0 interface goes down weight becomes 190, which is below configured threshold. This will overthrow the respective AVF. That AVF will go into Listen state and stops forwarding.
  • For GLBP group 20, R1 is Active AVG with priority 125.
  • For GLBP group 21. R4 is Active AVG with priority 125.
  • Cross links have more OSPF interface cost. Preferred links are R1 s0/0 - R3 s0/0 from Host 1 to Host 2 and R4 s0/0 to R2 s0/0 from Host 2 to Host 1.
  • Active AVG is aware of all AVF's states present in Active AVG as well as Standby AVG.
  • Observe the "sh glbp" output when R1 s0/0 goes down. Weight goes down by 10, i.e. 190. This causes the AVF's to go into Listen state. Both Active AVF's are in Standby AVG router R2 (192.168.56.251). 
  • Normal operation (no link or router down)
    • GLBP group 20 - 192.168.56.252
      • Active AVG - R1
      • Standby AVG - R2
      • Active AVF's - R1 Forwarder 1, R2 Forwarder 2
    • GLBP group 21 - 192.168.57.252
      • Active AVG - R4
      • Standby AVG - R3
      • Active AVF's - R4 Forwarder 1, R3 Forwarder 2
  • For example, Lets say if R1 s0/0 goes down, then
    • GLBP group 20 - 192.168.56.252
      • Active AVG - R1
      • Standby AVG - R2
      • Active AVF's - R2 Forwarder 1, R2 Forwarder 2
  • Active AVG priority is manually specified, it does not depend upon Weight. Preemption is enabled too overthrow lower priority routers.
Router Configurations - 

R1 - 
---------------------------------------------------------------------------------------------------------------------------------
track 1 interface Serial0/0 ip routing
!
!
interface Loopback1
 ip address 199.199.199.199 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.56.250 255.255.255.0
 duplex auto
 speed auto
 glbp 20 ip 192.168.56.252
 glbp 20 priority 125
 glbp 20 preempt
 glbp 20 weighting 200 lower 191
 glbp 20 authentication text ninja
 glbp 20 weighting track 1 decrement 10
!
interface Serial0/0
 ip address 11.1.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 12.1.1.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf cost 80
!
router ospf 1
 log-adjacency-changes
 network 11.1.1.0 0.0.0.255 area 0
 network 12.1.1.0 0.0.0.255 area 0
 network 192.168.56.0 0.0.0.255 area 0

R2 -
---------------------------------------------------------------------------------------------------------------------------------
track 1 interface Serial0/0 ip routing
!
!
interface Loopback1
 ip address 198.198.198.198 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.56.251 255.255.255.0
 duplex auto
 speed auto
 glbp 20 ip 192.168.56.252
 glbp 20 priority 120
 glbp 20 preempt
 glbp 20 weighting 200 lower 191
 glbp 20 authentication text ninja
 glbp 20 weighting track 1 decrement 10
!
interface Serial0/0
 ip address 14.1.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 13.1.1.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf cost 80
!
router ospf 1
 log-adjacency-changes
 network 13.1.1.0 0.0.0.255 area 0
 network 14.1.1.0 0.0.0.255 area 0
 network 192.168.56.0 0.0.0.255 area 0

R3 - 
---------------------------------------------------------------------------------------------------------------------------------
track 1 interface Serial0/0 ip routing
!
!
interface Loopback1
 ip address 195.195.195.195 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.57.250 255.255.255.0
 duplex auto
 speed auto
 glbp 21 ip 192.168.57.252
 glbp 21 priority 120
 glbp 21 preempt
 glbp 21 weighting 200 lower 191
 glbp 21 authentication text ninja
 glbp 21 weighting track 1 decrement 10
!
interface Serial0/0
 ip address 11.1.1.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 13.1.1.2 255.255.255.0
 ip ospf network point-to-point
 ip ospf cost 80
!
router ospf 1
 log-adjacency-changes
 network 11.1.1.0 0.0.0.255 area 0
 network 13.1.1.0 0.0.0.255 area 0
 network 192.168.57.0 0.0.0.255 area 0

R4 -
---------------------------------------------------------------------------------------------------------------------------------
track 1 interface Serial0/0 ip routing
!
!
interface Loopback1
 ip address 191.191.191.191 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.57.251 255.255.255.0
 duplex auto
 speed auto
 glbp 21 ip 192.168.57.252
 glbp 21 priority 125
 glbp 21 preempt
 glbp 21 weighting 200 lower 191
 glbp 21 authentication text ninja
 glbp 21 weighting track 1 decrement 10
!
interface Serial0/0
 ip address 14.1.1.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 12.1.1.2 255.255.255.0
 ip ospf network point-to-point
 ip ospf cost 80
!
router ospf 1
 log-adjacency-changes
 network 12.1.1.0 0.0.0.255 area 0
 network 14.1.1.0 0.0.0.255 area 0
 network 192.168.57.0 0.0.0.255 area 0

Normal Operation R1 output - 
---------------------------------------------------------------------------------------------------------------------------------
R1#sh glbp
FastEthernet0/0 - Group 20
  State is Active
    2 state changes, last state change 00:06:50
  Virtual IP address is 192.168.56.252
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.220 secs
  Redirect time 600 sec, forwarder time-out 14400 sec
  Preemption enabled, min delay 0 sec
  Active is local
  Standby is 192.168.56.251, priority 120 (expires in 9.276 sec)
  Priority 125 (configured)
  Weighting 200 (configured 200), thresholds: lower 191, upper 200
    Track object 1 state Up decrement 10
  Load balancing: round-robin
  There are 2 forwarders (1 active)
  Forwarder 1
    State is Active
      1 state change, last state change 00:06:40
    MAC address is 0007.b400.1401 (default)
    Owner ID is c801.1034.0000
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is local, weighting 200
  Forwarder 2
    State is Listen
    MAC address is 0007.b400.1402 (learnt)
    Owner ID is c802.1034.0000
    Redirection enabled, 598.528 sec remaining (maximum 600 sec)
    Time to live: 14398.312 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 192.168.56.251 (primary), weighting 200 (expires in 7.884 sec)

R1 output with R1 s0/0 down -
---------------------------------------------------------------------------------------------------------------------------------
R1#sh glbp
FastEthernet0/0 - Group 20
  State is Active
    2 state changes, last state change 00:08:54
  Virtual IP address is 192.168.56.252
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.368 secs
  Redirect time 600 sec, forwarder time-out 14400 sec
  Preemption enabled, min delay 0 sec
  Active is local
  Standby is 192.168.56.251, priority 120 (expires in 8.396 sec)
  Priority 125 (configured)
  Weighting 190, low (configured 200), thresholds: lower 191, upper 200
    Track object 1 state Down decrement 10
  Load balancing: round-robin
  There are 2 forwarders (0 active)
  Forwarder 1
    State is Listen
      2 state changes, last state change 00:00:10
    MAC address is 0007.b400.1401 (default)
    Owner ID is c801.1034.0000
    Redirection enabled
    Preemption enabled, min delay 30 sec
    Active is 192.168.56.251 (secondary), weighting 200 (expires in 8.396 sec)
  Forwarder 2
    State is Listen
    MAC address is 0007.b400.1402 (learnt)
    Owner ID is c802.1034.0000
    Redirection enabled, 599.108 sec remaining (maximum 600 sec)
    Time to live: 14398.904 sec (maximum 14400 sec)
    Preemption enabled, min delay 30 sec
    Active is 192.168.56.251 (primary), weighting 200 (expires in 8.448 sec)
R1#

So GLBP provides more control over the Network than HSRP/VRRP. Happy Networking.

First Hop Redundancy Protocols Part 2 - VRRP Gateway redundancy with static cost based Shortest path OSPF routing

After HSRP priority tracker implementation, here is VRRP (Virtual Router Redundancy Protocol) implementation. VRRP is Open-standard protocol. VRRP has Master & Backup routers with same overthrow capability as in HSRP. Master & Backup can be decided on basis of priority. Interface tracking can be enabled in supporting devices. I am not using Interface tracking here. VRRP is generally used for Router redundancy with High-end router as Master followed by Mid-level router as fail-over to sustain traffic for Master maintenance period.

I have implemented OSPF(Open Shortest Path First) here to demonstrate fast convergence of OSPF protocol.OSPF network configured is point-to-point network as no boundary router is present here. Complete OSPF area is backbone area i.e. Area 0. This scenario typically represents Multihoming WAN corporate networks to increase network resiliency. I am using single area OSPF configuration as in regard to achieve VRRP. I will post Multi-area OSPF configuration of Stub & Not-so-Stub area (NSSA) in upcoming articles. VRRP does not use UDP as communication protocol, it uses IP at 112 port. VRRP uses multicast address 224.0.0.18. Only one router remains in "Master" state, rest of the configured routers remain in "Backup" state. Remember HSRP & VRRP are not Load-balancing protocols, they do not distribute connections on basis of MAC addresses or IP addresses or in Round-robin. GLBP does load-balancing.


Master Routers R1 & R3 are implemented typically with high end capability to support faster processing and convergence, whereas Backup Routers R3 & R4 are mid-range routers to handle traffic only till primary comes up after maintenance. Virtualbox Microcore Linux Virtual Machines interfaces are bridged with Cloud interfaces. Different port shut & Router failure scenarios are tested to observe the behavior. OSPF is a Link-state routing protocol. I also observed that for the same architecture EIGRP protocol took more time for convergence & route propagation. EIGRP uses Distance-Vector routing Algorithm.
  • In OSPF serial link has default cost of 64. OSPF interface cost can be set to prioritize the outbound interface for packet.
  • If the Interface on which VRRP is configured goes down, then VRRP goes into "Init" state & will no longer become "Master". "Backup" router next in priority then becomes "Master".
  • Backup router will only become Master if 
    • Master router fails & goes down
    • VRRP interface on Master router goes down
  • VRRP Virtual IP will always point to Master routers interface IP, even though no outbound interface is present to reach destination network. OSPF protocol is required to take care of this preventing blackhole situation.
  • Packets will be routed through best possible low cost interfaces, so combination of Master Routers with low cost links will be computed.
  • Route selection process happens fast in OSPF providing better performance.
  • OSPF can also send traffic from Master router (say R1) to Backup router (say R2) directly if the best possible low cost path is present.
  • As there is no BDR present here, point-to-point OSPF network type is needed to be configured to share route information's.
  • Serial Interfaces only are configured in Point-to-Point configuration. 
  • VRRP facing interfaces are in broadcast mode providing BDR status 
Routing changes - 
-----------------------------------------------------------------------------------------------------------------------------------------
Shut Interfaces                                         Master Routers        Host 1 to Host 2                Host 2 to Host 1     
-----------------------------------------------------------------------------------------------------------------------------------------
R3 f0/0                                                             R1,R4            SW1-R1-R2-R4-SW2          SW2-R4-R2-SW1                
R3 f0/0, R1 s0/1                                              R1,R4            SW1-R1-R2-R4-SW2          SW2-R4-R2-SW1                      
R3 f0/0, R1 s0/1,R3 s0/1                                R1,R4            SW1-R1-R2-R4-SW2          SW2-R4-R2-SW1              
R3 f0/0, R1 s0/1,R3 s0/1, R1 s0/0                R1,R4             SW1-R1-R2-R4-SW2          SW2-R4-R2-SW1                  
R3 f0/0, R1 s0/1,R3 s0/1, R1 s0/0, R1 f0/0  R2,R4             SW1-R2-R4-SW2                SW2-R4-R2-SW1            
R1 s0/0, R2 s0/0                                             R1,R3             SW1-R1-R4-SW2                SW2-R3-R2-SW1               


Router Configurations - 
R1 - 
-----------------------------------------------------------------------------------------------------------------------------------------
interface Loopback1
ip address 199.199.199.199 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.56.250 255.255.255.0
duplex auto
speed auto
vrrp 20 ip 192.168.56.252
vrrp 20 timers advertise 5
vrrp 20 priority 125
vrrp 20 authentication text ninja
!
interface Serial0/0
ip address 11.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 12.1.1.1 255.255.255.0
ip ospf network point-to-point
ip ospf cost 80
!
router ospf 1
log-adjacency-changes
network 11.1.1.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
network 192.168.56.0 0.0.0.255 area 0

R2 - 
-----------------------------------------------------------------------------------------------------------------------------------------
interface Loopback1                                               
 ip address 198.198.198.198 255.255.255.255                       
!                                                                  
interface FastEthernet0/0                                          
 ip address 192.168.56.251 255.255.255.0                             
 duplex auto                                                         
 speed auto                                                        
 vrrp 20 ip 192.168.56.252                                           
 vrrp 20 timers learn                                              
 vrrp 20 priority 120                                              
 vrrp 20 authentication text ninja                                   
!                                                                  
interface Serial0/0                                                
 ip address 14.1.1.1 255.255.255.0                                   
 ip ospf network point-to-point                                    
!                                                                  
interface FastEthernet0/1                                          
 no ip address                                                          
 shutdown                                                          
 duplex auto                                                          
 speed auto                                                        
!                                                                  
interface Serial0/1                                                
 ip address 13.1.1.1 255.255.255.0                                   
 ip ospf network point-to-point                                    
 ip ospf cost 80                                                   
!                                                                  
router ospf 1                                                      
 log-adjacency-changes                                                
 network 13.1.1.0 0.0.0.255 area 0                                                  
 network 14.1.1.0 0.0.0.255 area 0                                   
 network 192.168.56.0 0.0.0.255 area 0                               

R3 - 
-----------------------------------------------------------------------------------------------------------------------------------------
interface Loopback1                                                
 ip address 195.195.195.195 255.255.255.255                        
!                                                                  
interface FastEthernet0/0                                          
 ip address 192.168.57.250 255.255.255.0                            
 duplex auto                                                         
 speed auto                                                       
 vrrp 21 ip 192.168.57.252                                        
 vrrp 21 timers advertise 5                                        
 vrrp 21 priority 125                                              
 vrrp 21 authentication text ninja                                   
!                                                                  
interface Serial0/0                                                
 ip address 11.1.1.2 255.255.255.0                                    
 ip ospf network point-to-point                                    
!                                                                  
interface FastEthernet0/1                                          
 no ip address                                                        
 shutdown                                                          
 duplex auto                                                        
 speed auto                                                        
!                                                                  
interface Serial0/1                                                
 ip address 13.1.1.2 255.255.255.0                                    
 ip ospf network point-to-point                                    
 ip ospf cost 80                                                        
!                                                                 
router ospf 1                                                     
 log-adjacency-changes                                               
 network 11.1.1.0 0.0.0.255 area 0                                 
 network 13.1.1.0 0.0.0.255 area 0                                   
 network 192.168.57.0 0.0.0.255 area 0                             


R4 -
-----------------------------------------------------------------------------------------------------------------------------------------
interface Loopback1                                               
 ip address 191.191.191.191 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.57.251 255.255.255.0
 duplex auto
 speed auto
 vrrp 21 ip 192.168.57.252
 vrrp 21 timers learn
 vrrp 21 priority 120
 vrrp 21 authentication text ninja
!
interface Serial0/0
 ip address 14.1.1.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 12.1.1.2 255.255.255.0
 ip ospf network point-to-point
 ip ospf cost 80
!
router ospf 1
 log-adjacency-changes
 network 12.1.1.0 0.0.0.255 area 0
 network 14.1.1.0 0.0.0.255 area 0
 network 192.168.57.0 0.0.0.255 area 0

OSPF Interface output on R1 - 
-----------------------------------------------------------------------------------------------------------------------------------------
R1#sh ip ospf int
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.56.250/24, Area 0
  Process ID 1, Router ID 199.199.199.199, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 199.199.199.199, Interface address 192.168.56.250
  Backup Designated router (ID) 198.198.198.198, Interface address 192.168.56.251
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 4 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 198.198.198.198  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
Serial0/1 is up, line protocol is up
  Internet Address 12.1.1.1/24, Area 0
  Process ID 1, Router ID 199.199.199.199, Network Type POINT_TO_POINT, Cost: 80
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40                                            
    Hello due in 00:00:00                                            
  Index 2/2, flood queue length 0                                    
  Next 0x0(0)/0x0(0)                                                               
  Last flood scan length is 1, maximum is 1                          
  Last flood scan time is 0 msec, maximum is 4 msec                  
  Neighbor Count is 1, Adjacent neighbor count is 1                  
    Adjacent with neighbor 191.191.191.191                                     
  Suppress hello for 0 neighbor(s)                                               
Serial0/0 is up, line protocol is up                                           
  Internet Address 11.1.1.1/24, Area 0                                            
  Process ID 1, Router ID 199.199.199.199, Network Type                           POINT_TO_POINT, Cost: 64                                                        
  Transmit Delay is 1 sec, State POINT_TO_POINT,                                
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5                                                                    
    oob-resync timeout 40                                            
    Hello due in 00:00:02                                            
  Index 1/1, flood queue length 0                                    
  Next 0x0(0)/0x0(0)                                                           
  Last flood scan length is 1, maximum is 1                          
  Last flood scan time is 4 msec, maximum is 4 msec                  
  Neighbor Count is 1, Adjacent neighbor count is 1                  
    Adjacent with neighbor 195.195.195.195                                  
  Suppress hello for 0 neighbor(s)                                            
R1#                                                               


OSPF Neighbor information for R1 - 
-----------------------------------------------------------------------------------------------------------------------------------------
R1#sh ip ospf neighbor                                                                
Neighbor ID    Pri State   Dead Time Address         Interface                 
198.198.198.198 1  FULL/BDR 00:00:38 192.168.56.251  FastEthernet0/0 
191.191.191.191 0  FULL/  - 00:00:30 12.1.1.2        Serial0/1                   
195.195.195.195 0  FULL/  - 00:00:34 11.1.1.2        Serial0/0                    
R1#                                                                  

BDR - Backup designated Router, this is due to the Broadcast Network type for the R1 f0/0 interface present. From the First line in neighbor information, R2 f0/0 interface will become Designated router if current designated router has problem or fails. R2 f0/0 has IP address 192.168.56.251 which is backup VRRP IP address present in VRRP group 20. Rest of the Serial links are Point-to-Point.
That's it guys, Njoy Networking.